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Vyng Messaging

• Нужно больше мессенджеров!


• Неделя мессенджеров. Количество 
слайдов с чатиками увеличивается в 2 
раза
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План

• Отрисовка: 101

• Поиск проблем

• Анализ разметки

• Влияние наложения

• Удалённое наблюдение
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Скорость UI



Что же видят люди?
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Что же видят люди?

• «Обратная связь»

• Время появления ожидаемых данных

• FPS - количество кадров в секунду
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FPS



Кадры решают всё
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Кадры решают всё

• 10 кадров в секунду

• 24 кадра в секунду

• 60 кадров в секунду

• 120 кадров в секунду
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0 кадров в секунду



16 мс



16 мс
~ 1000 мс / 60 кадров



 VSync  



Screen tearing  



Choreographer and VSync
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Choreographer and VSync

• Ввод
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Choreographer and VSync

• Ввод
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Choreographer and VSync

• Ввод

• Анимации

• Создание View

• Отрисовка View
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Display Lists
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Display Lists

• Кэш операций рендеринга

• Не содержит логики

• Каждой View - по Display List!

https://www.youtube.com/watch?v=v9S5EO7CLjo

API 11 (Android 3.0)




Display List

Save 3

DrawPatch

Save 3

ClipRext 20.00, 4.00, 99.00, 44.00, 1

Translate 20.00, 12.00

DrawText 9, 18, 9, 0.00, 19.00, 0x17e898

Restore

RestoreToCount 0
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Buffer updates
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Dropped frames
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Причины
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Причины

• Деятельность в главном потоке

• IO

• «Дорогие» операции

• Проблемы разметки

• Большая вложенность

• Наложение

• Прозрачность

• Большое количество view
!20



Сложности разметки



Инструменты

• Profile GPU rendering


• HierarchyViewer


• Debug GPU overdraw


• SysTrace


• TraceView
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Очерчиваем проблему
Сложности разметки



Инструменты

• Profile GPU rendering


• Gfxinfo


• SysTrace
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Профилируем отрисовку GPU
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Профилируем отрисовку GPU
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Информация профилирования
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Информация профилирования

• Ожидание главного потока

• Measure/layout/animation/input handling

• Обновление DisplayLists (onDraw())

• Передача изображений (bitmaps) в GPU

• Отображение DisplayLists на экран

• Смена буфера GPU
!27https://developer.android.com/studio/profile/inspect-gpu-rendering.html



Профилируем отрисовку GPU

• Оранжевый  — смена буфера GPU


• Тёмно-зелёный - ожидание, пока 
главный поток освободится
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GPU monitor

• До Android Studio 3.0

!29
https://developer.android.com/studio/profile/am-gpu.html

Возможная причина: https://stackoverflow.com/a/36345160/3675659
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Gfxinfo

> adb shell dumpsys gfxinfo   
          <your.package> framestats
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Gfxinfo

> adb shell dumpsys gfxinfo   
          <your.package> framestats



Агрегированные данные

• Total frames rendered: 1836


• Janky frames: 1344 (73.20%)


• 90th percentile: 31ms


• 95th percentile: 40ms


• Number Slow UI thread: 187


• Number Slow bitmap uploads: 17


• Number Slow issue draw commands: 1145
!31



Ничто не идеально
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Ничто не идеально
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Ничто не идеально
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Тут нормально, там не очень…
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–Nimbledroid

«86% Пользователей удаляют медленные 
приложения сразу после установки».

http://blog.nimbledroid.com/2015/09/03/why-you-should-care-about-app-performance.html



— Peter Drucker, Writer, Management Consultant

“What gets measured gets managed”



Hierarchy Viewer
Сложности разметки



 Hierarchy Viewer  



Запуск Hierarchy Viewer

1. Tools -> Android -> Enable ADB 
integration


2. Tools -> Android -> Android Device 
Monitor


3. Запуск профилировки
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Запуск Hierarchy Viewer

1. Tools -> Android -> Enable ADB 
integration


2. Tools -> Android -> Android Device 
Monitor


3. Запуск профилировки
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Цветные кружочки



Цветные кружочки

• Measure


• Layout


• Draw
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Цветные кружочки

• Зеленый - быстрее 50%


• Жёлтый - медленнее 50%


• Красный - самый медленный
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Всё относительно

• 1 view


• Measure: 0,023 ms


• Layout: 0,001 ms


• Draw: 0,426 ms

!42

0.5 мс



Всё относительно

• 138 views


• Measure: 4,461 ms


• Layout: 1,026 ms


• Draw: 14,723 ms
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20 мс



300 спартанцев

• 327 views


• Measure: 21,420 ms


• Layout: 17,690 ms


• Draw: 3,863 ms
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20 мс



Раз экранчик, два экранчик…
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Раз экранчик, два экранчик…

• 498 views


• Measure: 4,101 ms


• Layout: 106,855 ms


• Draw: 9,173 ms

!46

120 мс



To push or not to push?

• 31 views


• Measure: 0,427 ms


• Layout: 4,818 ms


• Draw: 0,923 ms

!47

6 мс



To push or not to push?

void setCurrentChatView(…) { 
  … // Подготовка транзакции 
   router.pushController(transaction); 
} 

Аналогично fragmentTransaction.add() 
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ViewStub

<ViewStub
   android:id=«@+id/groupAvatarImage1"
   android:inflatedId="@+id/groupAvatarImage1"
   android:layout=«@layout/complex_layout"
   // width, height/>

!49

setVisibility(int)
inflate()



ViewStub vs Dynamic
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ViewStub vs Dynamic

• Вся разметка в одном месте

• Проще установить позицию в разметке

• Видно в предпросмотре

• Размер - 0

• Пустые onDraw/onLayout/onMeasure

!50



 Лишние контейнеры  



 Лишние контейнеры  



Lint check

• Android >  
          Lint >  
             Performance
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Оптимизация?
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Тестируйте на слабых устройствах
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• Эмулятор  
Macbook Pro 2017


• 280 views


• ~ 11 ms



Тестируйте на слабых устройствах
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• Эмулятор  
Macbook Pro 2017


• 280 views


• ~ 11 ms

• Samsung  
Galaxy J2


• 167 views


• ~ 96 ms



Доверяй, но проверяй

@Override 
protected void onDraw(Canvas canvas) { 
  super.onDraw(canvas); 
  SystemClock.sleep(1000); 
}
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Доверяй, но проверяй

@Override 
protected void onDraw(Canvas canvas) { 
  super.onDraw(canvas); 
  SystemClock.sleep(1000); 
}
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Такое разное время
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Такое разное время

• Wall clock time
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Такое разное время

• Wall clock time

• Thread time
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Hierarchy Viewer - thread time

@Override 
protected void onDraw(Canvas canvas) { 
  super.onDraw(canvas); 
  fib(39); 
} 

public static int fib(int n) { 
  if (n == 0 || n == 1) { 
    return 1; 
  } else { 
    return fib(n - 1) + fib(n - 2); 
  } 
}
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Display lists

Root  (ConversationListItemView 0x85463300) 
  (Translate (left, top) 0, 869) 
  (ClipRect 0, 0, 1080, 212) 
  RenderNodeOp [1080.00 x 212.00]  (ColorDrawable 0x86660880) 
    RectOp [1080.00 x 212.00] 
  /RenderNode(ColorDrawable 0x86660880) 
  RenderNodeOp [1080.00 x 212.00]  (FrameLayout 0x85464480) 
    (ClipRect 0, 0, 1080, 212) 
    RenderNodeOp [1080.00 x 212.00]  (ColorDrawable 0x86660c00, empty) 
    /RenderNode(ColorDrawable 0x86660c00) 
    RenderNodeOp [1080.00 x 212.00]  (LinearLayout 0x85464800) 
      (ClipRect 0, 0, 1080, 212) 
      RenderNodeOp [1080.00 x 212.00]  (RippleDrawable 0x86660f80, empty) 
      /RenderNode(RippleDrawable 0x86660f80)
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Display lists

Root  (ConversationListItemView 0x85463300) 
  (Translate (left, top) 0, 869) 
  (ClipRect 0, 0, 1080, 212) 
  RenderNodeOp [1080.00 x 212.00]  (ColorDrawable 0x86660880) 
    RectOp [1080.00 x 212.00] 
  /RenderNode(ColorDrawable 0x86660880) 
  RenderNodeOp [1080.00 x 212.00]  (FrameLayout 0x85464480) 
    (ClipRect 0, 0, 1080, 212) 
    RenderNodeOp [1080.00 x 212.00]  (ColorDrawable 0x86660c00, empty) 
    /RenderNode(ColorDrawable 0x86660c00) 
    RenderNodeOp [1080.00 x 212.00]  (LinearLayout 0x85464800) 
      (ClipRect 0, 0, 1080, 212) 
      RenderNodeOp [1080.00 x 212.00]  (RippleDrawable 0x86660f80, empty) 
      /RenderNode(RippleDrawable 0x86660f80)

!59



Hierarchy Viewer. Заключение
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Hierarchy Viewer. Заключение

• 10 измерений — 10 уникальных результатов

• Красный != плохо

• Оптимизации нужно подтверждать числами

• Метрики снимаются только вручную…
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Немного о грустном

Hierarchy Viewer is no longer being developed
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 Layout inspector  



Overdraw
Сложности разметки



Профилируем отрисовку GPU
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Слои. Photoshop? Не только

!65https://www.youtube.com/watch?v=T52v50r-JfE



Отрисовка виджетов

• onMeasure() - желаемый размер


• onLayout() - фактический размер, положение


• onDraw() - отрисовка в Display Lists
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Ну и что?

• Перерисовывка много раз


• Каскадный вызов  
requestLayout()

!67https://medium.com/google-developers/simplify-complex-view-hierarchies-5d358618b06f



Hierarchy View → Photoshop
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Hierarchy View → Photoshop

• Простая визуализация
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Hierarchy View → Photoshop

• Простая визуализация

• Легко найти лишние слои
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Hierarchy View → Photoshop

• Простая визуализация

• Легко найти лишние слои
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Слои виджетов
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Слои виджетов
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Слои виджетов

<LinearLayout 
  android:background=«@color/white"> 

  <FrameLayout 
    android:background=«@color/white"> 

    <android.support.v7.widget.RecyclerView 
      android:background=«@color/white"> 

    </android.support.v7.widget.RecyclerView> 
  </FrameLayout> 
</LinearLayout>
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До и после
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До и после
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Аватарки. Велосипед

• Overdraw - красный
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Аватарки. Велосипед

• Overdraw - красный
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Аватарки. Велосипед

• Overdraw - красный

• Реализация - 4 слоя
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Аватарки. Велосипед

• Overdraw - красный

• Реализация - 4 слоя

• 4,2 мс на отрисовку
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Аватарки. Готовое решение
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Аватарки. Готовое решение

• Библиотека от Tango Agency
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Аватарки. Готовое решение

• Библиотека от Tango Agency

• Статья о решении*

!73*https://medium.com/tangoagency/avatar-view-for-android-apps-c00091e85ab8



Аватарки. Готовое решение

• Библиотека от Tango Agency

• Статья о решении*

• Overdraw - синий
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Аватарки. Готовое решение

• Библиотека от Tango Agency

• Статья о решении*

• Overdraw - синий

• Отрисовка… 50 мс!

!73*https://medium.com/tangoagency/avatar-view-for-android-apps-c00091e85ab8



Привет, Кэп!
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Привет, Кэп!

• Иногда готовое решение лучше


• Но велосипеды бывают неплохими


• Главное - измерять!
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Scalpel
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Scalpel

• Не нужно Фотошопа
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Scalpel

• Не нужно Фотошопа

• Требует добавления специальную 
ViewGroup
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Scalpel

• Не нужно Фотошопа

• Требует добавления специальную 
ViewGroup

• Решение: 
https://github.com/gaket/scalpel

!75

https://github.com/gaket/scalpel


Overdraw
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Overdraw

• Легко проверить
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Overdraw

• Легко проверить

• Легко исправить
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Overdraw

• Легко проверить

• Легко исправить

• Не стоит впадать в крайности

!76



Отступать некуда
Позади Москва



Android vitals
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Android vitals
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Android vitals
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Android vitals
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Android vitals
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Frozen Frames



Render time



Render time anomaly



Подводя итоги



• SysTrace


• TraceView (CPU Monitor)

За кадром



— Instagram Engineering blog

«At Instagram we’ve spent the last year reimagining 
and redesigning our Android app to work better for 

our users».

https://engineering.instagram.com/building-a-better-instagram-app-for-android-c08f973662b



• Оптимизации - не всегда


• Рука на пульсе - обязательно!

Стоит ли овчинка выделки



Slide title

Vyng 
Is  
Hiring

• Remote positions

• Senior Android Developer

• Senior Back-End Developer (NodeJs, React)

 
Details: 
Telegram: @gaket, @travelernote 
https://www.linkedin.com/in/gaket/

artur@vyng.me

Startup in California,  
We are making ringtones fun again :) 

https://www.linkedin.com/in/gaket/
mailto:artur@vyng.me


That’s all folks
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Профайлинг в примерах

Артур Бадретдинов, Vyng 

Telegram: @gaketo, @travelernote


Facebook: https://www.facebook.com/gakett


LinkedIn:  https://www.linkedin.com/in/gaket
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https://www.linkedin.com/in/gaket

