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Webinar Handout

A handy guide to the contents of the webinar, 
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What’s included

Learn more about the SketchUp ecosystem and 
some of the tools shown during the webinar.

What’s Included



SketchUp Ecosystem

A Winning Platform

LayOut

SketchUp 
for iPad

Trimble 
Connect

Viewer for QuestSketchUp 
for Desktop

Viewer 
for Mobile

V-Ray® 

Integrated 3rd-party tool

Scan-to-Design [Labs]

Sefaira

PreDesign

Scan Essentials

SketchUp 
for Web

Revit Importer

3D Warehouse

Extension Warehouse
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Not just a 3D modelling application, we offer a suite of products 
built to enhance and accelerate a designer’s workflow.



SketchUp for Desktop is useful from the earliest stages of 

design all the way to final project delivery. Easy-to-use 

drawing tools are combined with the accuracy and detail 

needed to produce constructible models, stunning images, 

2D documentation, cost estimates and material schedules. 

Learn more >

Sketch in 3D faster than ever using SketchUp for iPad’s 

intuitive and versatile drawing tools — think Apple Pencil, 

multi-touch-gestures, and mouse and keyboard inputs. 

Store and access projects anytime in the cloud, and sync 

them across web, desktop, mobile, and tablet devices. 

SketchUp for iPad is fully context-enabled — pull in satellite 

imagery and 3D terrain data for site context, or situate your 

designs in the real-world using its AR capabilities.

Learn more >

With SketchUp for Web, the canvas for your next idea is just 

a browser tab away, all you need to get going is an internet 

connection. Our web-based modeler is a streamlined 

version of our desktop app that uses the same core 

technology. And, by saving projects to Trimble Connect, 

you’re always working on the most up-to-date version of a 

model; you can even look-up version history. 

Learn More > 

SketchUp for Desktop

SketchUp for iPad

SketchUp for Web

http://sketchup.com/products/sketchup-pro
http://sketchup.com/ipad
https://www.sketchup.com/products/sketchup-for-web


An online repository with millions of free models. Instantly 

add entourage and context to projects. Browse thousands 

of real-world products from recognized brands to specify 

appliances, furniture, floor coverings, and more.

Manufacturers leverage 3D Warehouse to increase brand 

awareness and generate leads by placing products in front 

of millions of potential buyers.

3D Warehouse >   Create an Account >

www.sketchup.com

There are hundreds of third-party add-ons to extend the 

tools and features of SketchUp. Improve workflows by 

reducing time-consuming, complex, or repetitive 

processes. There are extensions for photorealistic 

rendering, reporting, parametric modeling, animation, 

and more.

Visit Extension Warehouse >

Combine models with text and 2D vector illustrations for 

beautiful presentations, permit submittals, construction 

documents, and other dimensioned drawings. 3D models 

are dynamically linked to LayOut files, and changes in 

SketchUp are instantly mirrored to documents.  

Learn more >

3D Warehouse

Extension Warehouse

LayOut

https://3dwarehouse.sketchup.com/
https://help.sketchup.com/en/article/3000250
http://sketchup.com/pro
http://sketchup.com/products/extension-warehouse
http://sketchup.com/products/layout


From detailed high-rise buildings to interior floor plans, 

add realism into your projects using V-Ray for SketchUp. 

V-Ray’s powerful raytracing engine gives you access to 

your own virtual digital camera, plus you can access 

interactive, real-time visualizations as you model with 

V-Ray Vision. Create compelling imagery to present your 

design story, remove ambiguity, showcase your proposal’s 

merits to clients, and win more work. Learn more > 

V-Ray®

EXCLUSIVE TO SKETCHUP STUDIO

Unlock the power of point cloud data and increase your 

workflow efficiency. Easily access, view and create 3D 

assets from terrestrial scans, photogrammetry, lidar 

sensors, mobile mapping, and drone captures. Import, 

view, and transform this scan data into an invaluable 3D 

asset by directly modeling onto point clouds using 

SketchUp’s native tools. Windows only Learn more >

EXCLUSIVE TO SKETCHUP STUDIO

SketchUp’s Revit Importer is a native functionality right 

within the Desktop modeling environment. It enables 

users to translate Revit families to optimized SketchUp 

components for quick, creative iteration at any project 

phase. Windows only Learn More >

EXCLUSIVE TO SKETCHUP STUDIO

Revit Importer

Scan Essentials

http://www.sketchup.com/products/v-ray
http://sketchup.com/products/scan-essentials
https://drive.google.com/open?id=1JGORiiRD8f8vA2MDvLbwhMJCDB66S0ae&usp=drive_copy


PreDesign is a new way to start your designs. With 

PreDesign, you can easily connect the dots between 

climate and concept design at the start of your project. 

Present compelling graphics to clients and steer your 

projects in the right direction.

Learn more >

Trimble Connect is a cloud-based platform that connects 

the right people to the right constructible data, at the right 

time. View, share, and access project information from 

anywhere at anytime.

Learn More >

PreDesign

Trimble Connect

Sefaira
Bring insightful building performance simulations to the 

conceptual design phase using Sefaira’s energy and 

daylight analysis plugins in SketchUp. Dive deeper by 

assessing passive strategies for lower loads and active 

HVAC sizing in Sefaira’s web app. Generate results 

powered by industry-accredited analysis engines within 

minutes.

Learn more >

http://sketchup.com/products/predesign
http://sketchup.com/trimble-connect
https://www.sketchup.com/products/sefaira


SketchUp Viewer for 
Mobile
Access models from 3D Warehouse, Trimble Connect, or 

other cloud storage apps on mobile. View and present models 

with the familiar orbit, pan, and zoom tools. The viewer 

supports scenes, fly-through animations, layers, section 

planes, and styles. 

Use AR features to merge 3D models with real-world 

context; reimagine room layouts, evaluate proposals in 

context or review projects.

Download Viewers >

www.sketchup.com

 

SketchUp Viewer for 
Meta Quest
Experience your 3D SketchUp models completely 

untethered in immersive mode or enjoy our new Home 

Environment to explore your 3D model in tabletop mode. 

Cycling through scenes within a model facilitates rapid 

decision making and can show construction sequencing.

Download Viewer >

https://www.sketchup.com/products/sketchup-viewer/downloads
http://sketchup.com/pro
https://www.oculus.com/experiences/quest/9874528232572675/


What’s New in SketchUp 2024

Unpack the latest tools available in SketchUp 2024

www.sketchup.com

http://sketchup.com/pro


What’s New in SketchUp 2024

Ambient Occlusion
Add visual emphasis and perceived depth at model 

edges with a new global style setting called Ambient 

Occlusion. This new feature can be tailored to 

produce stylized visuals similar to clay or white 

models without the need of a rendering engine and is 

available on Desktop, iPad, and visible in LayOut. 

Ambient Occlusion Video >

Top new features in 2024
SketchUp for Desktop 2024 offers a new layer of 

realism and innovative visual styles directly within 

the SketchUp interface, along with updates that 

amplify productivity. 

2024 Launch blog > | SketchUp 2024 Video >

New graphics engine
SketchUp graphics engine got an upgrade! This new 

graphics engine takes advantage of emerging 

hardware and software technologies, providing 

notable improvements in file navigation and 

responsiveness. 

*Performance improvements are dependent on your device. 

Learn more here.

https://www.youtube.com/watch?v=7qF8V4A1YGs
https://blog.sketchup.com/home/unlock-enhanced-visuals-inside-sketchup-2024-2
https://www.youtube.com/watch?v=xlWcofZnrro
https://help.sketchup.com/en/sketchup/graphics


Add Location
Enjoy more precise terrain data and simplified imports 

in Add Location, raising your confidence in bringing 

real-world data into SketchUp. Select low density for 

lighter, faster files and higher density for more 

detailed and precise terrain.

Add Location Video > | More Information >

Ground Mesh Tool

This new Scan Essentials tool allows you to quickly 

and efficiently turn a terrain point cloud into an 

accurate, quad-face based, ground mesh with a 

chosen resolution. Choose from Fit Cloud, 

Rectangular, and Bounded options.

Using Scan Essentials Article > 

IFC Improvements
Improvements to IFC import and export boost 

SketchUp’s effectiveness in advanced BIM 

workflows. Benefit from enhanced mapping to IFC 

class attributes, and maintain data-rich models for 

improved project performance and BIM exports.

Learn more about using IFC file in SketchUp >

What’s New in SketchUp 2024

EXCLUSIVE TO SKETCHUP STUDIO

https://www.youtube.com/watch?v=-jOXDByVnVM
https://www.sketchup.com/products/add-location
https://help.sketchup.com/en/scan-essentials-sketchup/using-scan-essentials
https://help.sketchup.com/en/sketchup/classifying-objects


Link Sharing functionality is now on Desktop, 

matching the capabilities of iPad and Web. Available 

through the File menu or the new Trimble Connect 

toolbar, this tool generates a link to a view-only 

version of your SketchUp model in SketchUp for 

Web's Viewer.

Give it a try | Link Sharing Video

What’s New in SketchUp 2024

Link Sharing

Import and export functionality for both USDZ and 

gITF files is now available. SketchUp opens up new 

possibilities for advanced visualization workflows 

and seamless transitions to and from 

industry-standard digital content creation tools.

Don’t forget to check out this blog post  

New 3D file formats

2024 release introduces Draft Mode, improved file 

support, updates to LayOut inferencing and 

Versionless to streamline your workflows within 

LayOut. Enjoy more efficient navigation, faster 

performance, and visual depth with AO even with the 

most developed, complex LayOut files.

Learn more here 

LayOut improvements

https://app.sketchup.com/share/tc/northAmerica/KX57ouqMX-o?stoken=ZBG1ZY0jSzalYsgaXOooXyiIHU89lfZjG_HLIvcLqxp_nt4AL14HpNUc5ZEezOGX&source=desktop
https://www.youtube.com/watch?v=mDddzI6ePVk
https://video.sketchup.com/webinar-advanced/watch/Lzd9Lq3xPTEv198XQxYYhk?&mkt_tok=NjQ1LUNPSi0zNDEAAAGAhlrqwtUDmv5XyuIGyU4Rk9bRIiKsy9BKrOzlkqwUqBNmXbDt6YlDSP4g285_JGSw36g2dgscVw2HVfIMBQ
https://video.sketchup.com/webinar-advanced/watch/Lzd9Lq3xPTEv198XQxYYhk?&mkt_tok=NjQ1LUNPSi0zNDEAAAGAhlrqwtUDmv5XyuIGyU4Rk9bRIiKsy9BKrOzlkqwUqBNmXbDt6YlDSP4g285_JGSw36g2dgscVw2HVfIMBQ
https://video.sketchup.com/webinar-advanced/watch/Lzd9Lq3xPTEv198XQxYYhk?&mkt_tok=NjQ1LUNPSi0zNDEAAAGAhlrqwtUDmv5XyuIGyU4Rk9bRIiKsy9BKrOzlkqwUqBNmXbDt6YlDSP4g285_JGSw36g2dgscVw2HVfIMBQ
https://video.sketchup.com/webinar-advanced/watch/Lzd9Lq3xPTEv198XQxYYhk?&mkt_tok=NjQ1LUNPSi0zNDEAAAGAhlrqwtUDmv5XyuIGyU4Rk9bRIiKsy9BKrOzlkqwUqBNmXbDt6YlDSP4g285_JGSw36g2dgscVw2HVfIMBQ
https://blog.sketchup.com/home/sketchup-enables-advanced-3d-workflows-with-usd-and-nvidia-omniverse
https://help.sketchup.com/en/release-notes/sketchup-desktop-20240#engine


What’s New in SketchUp 2024

SketchUp for iPad 6.5
Scan, design, and collaborate — all on iPad.  

Scan-to-Design[Labs], will revolutionize your 

scanning, model creation, and design process. In 

addition, enhancements like Ambient Occlusion 

and Omnibar await you in this SketchUp for iPad 

update.

Blog post | Scan-to-Design video

Omnibar

New navigation tool with advanced search 

functionality that helps you find what you need 

faster and allows you to create and activate 

custom keyboard shortcuts.  

Watch Video

AVAILABLE ON SKETCHUP FOR IPAD

Scan-to-Design[Labs]

Give yourself a head start on conceptual design and 

capture as-built conditions quickly with this powerful 

LiDAR-scanning feature. Scan existing spaces and watch as 

SketchUp, powered by Canvas, Apple’s and Trimble’s 

cutting edge technology, transforms your scan data into an 

intelligently organized 3D SketchUp model.

AVAILABLE ON SKETCHUP FOR IPAD

Learn More  | Scan to Design Help Center 

https://blog.sketchup.com/home/scan-design-and-collaborate-all-on-ipad
https://www.youtube.com/watch?v=RNhB6YXUrrs
https://www.youtube.com/watch?v=_2HSExD_0jA
https://mobile.sketchup.com/dPnL/fv7rkbgk
https://help.sketchup.com/en/sketchup-ipad/scan-design-sketchup-labs


Extensions & Resources

Supercharge your SketchUp workflow with these must-have extensions.



Check out our online repository of 
extensions, Extension Warehouse, for a full 
list of certified extensions available to you.

If the Extension Warehouse is not quite 
enough for you, you may want to take a look 
at the extensions available on the 
SketchUcation Plugin Store (note you will 
need to register for a free account  to 
download from the Plugin Store).

Extensions

Whatever you do with SketchUp, odds are that there is an extension out there that will 
help you to do it better/quicker/easier. Extensions are bits of software that run inside of 
SketchUp that give you additional functionality within the native design environment.

Extension Warehouse
For information on installing extensions, 
check out this video for step-by-step 
instructions.

Installing extensions

750+ extensions might leave you feeling 
overwhelmed. We’ve shortlisted some 
essential SketchUp extensions that will 
improve the productivity of your team. 
Some of these plugins are free, but we 
have indicated the commercial extensions 
with a (C).

Not sure where to start?

Extension Warehouse

https://extensions.sketchup.com/
https://sketchucation.com/pluginstore
https://sketchucation.com/register.php
https://youtu.be/AFwVmc8G33Y
http://www.youtube.com/watch?v=AFwVmc8G33Y


Tips & Tricks | Import Data

Raster Image Import

SketchUp allows you to import images as textures, 

or references to start your project or enhance your 

model. 

More information

Skill Builder: Reference Images for Architecture

Curic Sun

Curic sun helps you visualize the position of the sun in 

relation to your building geometry. The extension 

helps designers understand how the sun traverses 

across the sky and how that direction might influence 

the position of windows or shading devices on your 

project.

More Information

PlaceMaker

This extension allows you to easily add context to 

your model by importing OpenStreetMap roads, 

buildings, paths, water bodies, trees, and high-res 

aerials. 

More information

SketchUp Video: SketchUp Extension Inspection 

- PlaceMaker

https://help.sketchup.com/en/sketchup/importing-and-exporting-image-files
https://youtu.be/cfoQf_8YYxg
https://extensions.sketchup.com/extension/49b56362-ada6-4bde-8213-8c68eb7763d1/curic-sun
https://extensions.sketchup.com/extension/dd87983f-abe6-4f4f-b87a-12312ab48b95/place-maker
https://www.youtube.com/watch?v=W7sAJywfQDk
https://www.youtube.com/watch?v=W7sAJywfQDk


Tips & Tricks| Document & Collaborate

LayOut for Interiors

Want to share your SketchUp model with others? 

Turning 3D models to 2D documents and 

presentations has never been easier using LayOut. 

More information

Tutorial: LayOut Essentials

Skill-Builder:  Let’s Talk LayOut

Video: Layout for Interiors

Generate Reports
SketchUp Pro can generate tabular reports

from the groups and components in your models. 

It's a simple operation, and provided you've set 

things up properly, it can save you a ton of time. 

More information

Skill Builder: SketchUp Skill Builder: Door and 

Window Schedule

Generate Cutlists

Have you ever struggled with organizing your 

project materials or creating efficient cut lists?

Open CutList extension generates cut lists, 

estimates, cutting diagrams, labels, exploded 

views, SVG, DXF for woodworking or similar 

projects.

More information

SketchUp Video: Open Cut List | SketchUp 

Woodworking Extension

www.sketchup.com

https://www.sketchup.com/products/layout
https://learn.sketchup.com/track/layout-essentials
https://www.youtube.com/playlist?list=PL-bndkJaV8A7da0R0SEEfb9DKMtCyMF_E
https://www.youtube.com/watch?v=2t9XiXpvoyE
https://blog.sketchup.com/article/generating-reports-your-models
https://youtu.be/6EhWN5Pk5qM
https://youtu.be/6EhWN5Pk5qM
https://extensions.sketchup.com/extension/00f0bf69-7a42-4295-9e1c-226080814e3e/open-cut-list
https://www.youtube.com/watch?v=x5jUVjjph4U
https://www.youtube.com/watch?v=x5jUVjjph4U
http://sketchup.com/pro


Purge
Your model stores components, styles, and 

materials that you’ve added to your model even if 

you’ve since erased or replaced them. SketchUp 

squirrels away these elements in case you need 

them later, but if you know that you don’t, tell 

SketchUp to let it all go. Select Window > Model 

Info, select Statistics in the sidebar on the left, and 

click the Purge Unused button.

More information

Fast Styles

When in the Styles tray, you see a small green 

stopwatch icon in the bottom right corner of a Style 

thumbnail that means that this Style features a 

combination of settings that won’t slow you down 

while modeling. SketchUp auto-detects Styles that 

use less processing power — this earns them the 

‘Fast Style’ badge.

More information

Scene Transitions
SketchUp can animate scenes of a 3D model by 

transitioning between scenes. However, that can 

slow you down. 

To disable it select View > Animation  > Settings 

or select Window>Model Info, select the 

Animation option in the sidebar and disable the 

‘Enable Scene Transitions’ checkbox.

More information

Tips & Tricks | Improve Performance

https://help.sketchup.com/en/sketchup/improving-performance#:~:text=Or%2C%20to%20purge%20all%20your,click%20the%20Purge%20Unused%20button.
https://blog.sketchup.com/article/what-are-fast-styles
https://help.sketchup.com/en/sketchup/animating-scenes


Selection Toys
You can use this extension as a selection filter to 

make smart selections in SketchUp. 

More information

JointPushPull

With JointPushPull you can easily add thickness to 

your surfaces and it even works with smoothed 

surfaces. To get this extension you have to register 

to SketchUcation.com.

More information

Tips & Tricks | Modeling Efficiency

TrueBend
TrueBend extension allows you bend geometry 

instances to a given degree, preserving the original 

length of the reference segment. 

More information

https://extensions.sketchup.com/extension/c9266b2c-0b55-4d21-a0a4-72e23b8a0fb4/selection-toys
https://sketchucation.com/plugin/715-jointpushpull
https://extensions.sketchup.com/extension/c9135b56-4492-449e-ac63-8c26b734ba39/true-bend


Tips & Tricks | Efficiency & Rendering

Enscape for SketchUp
Enscape™ is a real-time rendering and virtual reality 

extension that plugs directly into SketchUp. You can 

design, document, and visualize simultaneously from 

one model. 

Enscape allows you to work intuitively with accessible 

rendering that requires no prior specialized 

knowledge to use. It is the easiest and fastest way to 

turn your models into immersive 3D experiences.

More Information

Lumion for SketchUp
By pairing your SketchUp modeling with Lumion 

rendering, you can dramatically reduce the 

amount of time it takes to create beautiful images, 

videos and 360 panoramas of your designs.

More information

www.sketchup.com

https://extensions.sketchup.com/extension/bc35cf5e-f2bd-4b65-8d9f-827302d7df55/enscape-for-sketch-up-real-time-rendering-and-virtual-reality
https://lumion.com/sketchup-rendering.html
http://sketchup.com/pro


Learning Resources

SketchUp’s blog hosts our 

latest written content.

SketchUp Blog >

SketchUp’s official 

YouTube channel.

SketchUp TV > SketchUp Campus >

SketchUp’s formal 

learning platform.

Connect with us

Connect with SketchUp’s 

community and ask any technical 

questions.

SketchUp’s podcast  on 

iTunes.

SketchUp Forum > SketchUp Talk >

https://blog.sketchup.com/?utm_source=asset&utm_medium=pdf&utm_campaign=brochures&utm_content=text-link
https://www.youtube.com/user/SketchUpVideo/featured?utm_source=asset&utm_medium=pdf&utm_campaign=brochures&utm_content=text-link
https://learn.sketchup.com/?utm_source=asset&utm_medium=pdf&utm_campaign=brochures&utm_content=text-link
https://www.facebook.com/sketchup
https://www.instagram.com/sketchup_official/
https://twitter.com/sketchup
https://www.youtube.com/user/SketchUpVideo/
https://forums.sketchup.com/
https://podcasts.apple.com/us/podcast/sketchup-talk/id1382988782?mt=2

